Defecto crítico sin parche revelado en la extensión de WordPress WooCommerce
Entrada publicada el 29 | 04 | 2019

Si posee un sitio web de comercio electrónico creado en WordPress y con el complemento WooCommerce, tenga cuidado con una nueva vulnerabilidad sin parches que se ha hecho pública y que podría permitir que los atacantes pongan en peligro su tienda en línea.

Una empresa de seguridad de WordPress, llamada ” Vulnerabilidades de complementos “, que se ha convertido en un pícaro para protestar contra los moderadores del foro de soporte oficial de WordPress, ha vuelto a dejar de lado los detalles  y la vulnerabilidad de prueba de concepto de una falla crítica en un plugin de WordPress ampliamente utilizado. .

Para que quede claro, la vulnerabilidad no parcheada informada no reside en el núcleo de WordPress o en el propio complemento WooCommerce.

En cambio, la vulnerabilidad existe en un plugin , llamadoWooCommerce Checkout Manager , que amplía la funcionalidad de WooCommerce al permitir que los sitios de comercio electrónico personalicen formularios en sus páginas de pago y actualmente están siendo utilizados por más de 60,000 sitios web. La vulnerabilidad en cuestión es un problema de “carga arbitraria de archivos” que puede ser explotado por atacantes remotos no autenticados si los sitios vulnerables tienen la opción “Categorizar archivos subidos” habilitada dentro de la configuración del complemento WooCommerce Checkout Manager.

“Desde el aspecto más técnico, la vulnerabilidad se produce dentro del archivo ‘incluye / admin.php’ en la línea 2084 en la que la aplicación está moviendo los archivos dados a un directorio usando ‘move_uploaded_file’ sin una verificación previa adecuada de los archivos permitidos”, explica una publicación de blog publicada el jueves por la plataforma de seguridad de aplicaciones web WebARX, quien advirtió a sus usuarios después de que las Vulnerabilidades del Plugin hicieron pública la falla.

Si se explota, la falla podría permitir a los atacantes ejecutar código de script del lado del servidor en el contexto del proceso del servidor web y poner en peligro la aplicación para acceder o modificar datos u obtener acceso administrativo.

La versión 4.2.6 de WooCommerce Checkout Manager, que es el último complemento disponible en el momento de la escritura, es vulnerable a este problema.

Si su sitio web de WordPress está usando este complemento, se le recomienda que deshabilite la opción “Clasificar archivos cargados” en la configuración o deshabilite el complemento por completo hasta que esté disponible una nueva versión parcheada.

Esta no es la primera vez que la compañía llamada Vulnerabilidades del complemento reveló de manera inapropiada una falla no parchada en el público.

La compañía ha estado continuamente revelando vulnerabilidades en varios complementos de WordPress desde que tuvieron problemas con los moderadores del foro de WordPress.

Desde hace al menos dos años, el equipo que está detrás de las Vulnerabilidades de los Complementos ha estado publicando deliberadamente detalles de las vulnerabilidades recién descubiertas directamente en el foro de Soporte de WordPress, en lugar de informarlas directamente a los respectivos autores de los complementos, violando las reglas del foro.

En respuesta a este comportamiento inapropiado, los moderadores de WordPress.org finalmente incluyeron en la lista negra las vulnerabilidades de los complementos de su foro oficial después de múltiples advertencias y la prohibición de todas sus cuentas.

Sin embargo, esto no impidió que las Vulnerabilidades en los Complementos, que desde entonces comenzaron a revelar detalles de las nuevas vulnerabilidades del plugin de WordPress sin parches en su propio sitio web, pusieran en riesgo todo el ecosistema, los sitios web y sus usuarios.

 

WordPress Appliance - Powered by TurnKey Linux